WIFI connected but no Internet

Hi @dh2a,

I understand you’re using a smartwatch, and this will be an inconvenience, but would you be able to try turning off the phone’s Bluetooth for a little while, just long enough to see if the issue returns even when Bluetooth is turned off?

If it happens only when Bluetooth is turned on, then we would start investigating any apps you have on the phone that have Bluetooth permissions. We’ve seen some in the past cause Wi-Fi connectivity issues.

So I’m not suggesting you’re doomed to keep your Bluetooth turned off forever, but only that this is a troubleshooting step to determine whether we need to try to identify a rogue app with Bluetooth permissions.

I will give that a try, though it will be not easy to remember all the time… Not sure which will be the more troublesome, however. Forgetting to check my WI-FI connection when I return home (one step) or turning off my Bluetooth before I get home and then turning in back on when I get there and have checked my WI-FI. The big advantage to the smartwatch is when I am away, especially when driving as our state now has strict prohibitions against using phones in the car. With the smartwatch I can see who is calling, etc. at just a glance.

Thanks @dh2a,

Maybe Saturday you might have some time to test - perhaps a nice walk just to get out of range of the home Wi-Fi, turn off Bluetooth, and walk back.

Although, depending on where you are, a “nice walk” might not be possible this time of year. :cold_face:

Good Morning @dh2a,

Were you able to get the suggested nice walk in (weather permitting) or otherwise sort this?

1 Like

Weather here is not condusive to walks outdoors (temps in single digits yesterday) but my 5 recent experiences have been as follows: 1 occurance with smartwatch in airplane mode (no bluetooth) - no problem, phone connected to WIFI and internet; 3 occurances with smartwatch bluetooth connected - no problem, phone connected to WIFI and internet; 2 occurances with smartwatch bluetooth connected - WIFI connected but no internet. In one of these situations, I put the smartwatch in airplane mode, turning off internet and then swapped back and forth between my two WIFI nodes which is my usual remedy and it took about a dozen times before it reconnected to the internet. The other time it connected on the first swap.

So there is not yet a firm cause and affect but it appears to be somehow related to the bluetooth on the smartwatch. I do have an android tablet which of course does not have the smartwatch software but does connect to WIFI and the internet without fail.

Hi @dh2a,

Could you let us know what kind of smartwatch you’re using, and the app name that goes with it?

It might be possible to narrow this down some more, to a specific option within the app.

It is a Huawei (1st edition, I think there may be later models) and it is managed by a Wear OS application v 2.31 from the Android Play Store.

I do not have any of the devices you are experiencing problems with, but with many problems a good place to start is to ensure you have the latest and a clean version of the codes involved.

  • I just loaded Wear OS to my phone to check the code level and it is
    You may want to uninstall the current level and then download and install the latest code
1 Like

That is the same level that is installed on my phone. Sorry, I did not put in all of the trailing digits in my response.

ok, thanks for the confirmation. At this point the only thing I can think of to suggest is to clear the System Cache and the individual app cache for your watch.

Still working through this problem, as it still occurs from time to time. Does this phone (Moto G5 Plus) use IPv4 or IPv6? If both are available, which does it use?

Hi @dh2a,

In looking for the answer to your question about Ipv6, I ran across something else we’ve seen occasionally here in Community. Do you by any chance have your router set to “auto” select the channel? Some routers will select a channel higher than 10, and the G5+ can see only to channel 10 12

I do not believe IPv6 is the issue, my understanding is that Android 6 and above support IPv6.

When I look at the settings on my phone I see it is connected to the 5GHz side of the router which is set at channel 153 (??)). The other 2.4 GHz is set to auto and has a possibility of up to channel 11. My phone currently seems to be connected with an IP4 address which is what both the router show, and it is working just fine. At the bottom of the settings screen it also shows some IP6 addresses but the router does not show them.

I am watching to see how things go after I recently made a router change. Combing through the router settings I noticed that the IP6 internet interface was disabled. I tried several things to enable that interface and found that the 6to4 tunneling path would auto-configure and that turned on the IP6 internet interface. My private network devices all communicate with each other with IP6 but apparently know to use IP4 to go to the internet if the IP6 path is not available. I am guessing that the phone does not have that capability.

My current hypothesis is that perhaps the phone connected with IP6 to the router which did not have an active path to the internet. If it connected with IP4 then it did have a path and everything worked correctly. Since the problem with connectivity is relatively recent I am wondering if a router upgrade or phone upgrade or windows upgrade changed things which caused the problem. Are you aware if any phone changes in this area? That is why I asked if there was a preference in the phone software to choose IP4 vs IP6.

I have only 2 or 3 occasions since I made the change to observe phone behavior but so far things have worked they way they should. I will post again after I have had more occasions to check.

Hi @dh2a,

I’m going to correct my previous post, because I believe the phones can connect up to channel 12, it’s once a router on “auto” goes above those channels, the phone drops connectivity.

There haven’t been any changes I’m aware of in the RW app related to Wi-Fi connectivity. I don’t think your phone has received any Android updates recently, either. It looks like the last one was Feb, 2019.

Hi @dh2a,

Does the experience persist, or have things sorted?

No more problems this week after the change I made to the router that I described in a previous post.

1 Like
Message an
Expert customer