WIFI connected but no Internet

It may or not be related, but I had a strange issue this morning when I unplugged my phone I noticed I had no cell connection and when I went to ‘Mobile Network’ all the options were greyed out and would not allow me to change them. When I went to the Republic app it told me to install my SIM!! I powered it down and back up again and it took me to a screen that said my number was not established, and to reboot.
When I rebooted my cell network had returned to normal. WiFi was connected with no internet and I am finding that if I switch back and forth between the two nodes about 5-6 times I it get connected. So perhaps I have bigger problems ahead. I was not ready for another phone by a long ways. :frowning:

How did the Safe Mode instruction you’got’ differ from those that Republic Help published … so that information can be passed back to them for possible correction of the Help doc.

The help doc from Republic was very clear and that is what I used today and it worked precisely as it was described. I do not recall how I found safe mode yesterday, probably just from searching from my desktop - and as is the usual case, everyone one on the web has their own flavor of help (often misguided) and I didn’t take the time to do proper diligence.

The term Safe Mode in the Republic Wireless user forum is one of the many ‘keywords’ that are auto linked to the appropriate Safe Mode – Republic Help document. This was provided by Republic’s folks (through the efforts of @southpaw) to easily refer folks to the appropriate doc without introducing the usual copy/paste & typo that would otherwise occur.

I am still having this problem, perhaps 1 out of 3 times I return home after being away for a time. I thought it might be related to my driving a vehicle with an ‘inactive’ OnStar subscription, but it happens when I leave with another vehicle. I thought it might be related to when I use a fitness tracker with a BlueTooth connection to my phone, but it occurs even when I have not used it. The phone has a BlueTooth connection to a smart watch, but that I have connected all the time. I have verified that my router is at the most current level and have rebooted it numerous times but still have the occurrences when I return I have no internet. I do not seem to have any issues when I am away and the phone connects to Guest networks with no problems. My wife also has a Republic Wireless phone but has not seen this problem. And I have used this phone and router for over a year before the problem started occurring. So I agree, some application or some upgrade has introduced the problem. So what do I do now? Neither replacing the phone or the router is a guaranteed fix. It is a very irritating issue that I may reluctantly have to live with. :frowning:

Hi @dh2a,

I understand you’re using a smartwatch, and this will be an inconvenience, but would you be able to try turning off the phone’s Bluetooth for a little while, just long enough to see if the issue returns even when Bluetooth is turned off?

If it happens only when Bluetooth is turned on, then we would start investigating any apps you have on the phone that have Bluetooth permissions. We’ve seen some in the past cause Wi-Fi connectivity issues.

So I’m not suggesting you’re doomed to keep your Bluetooth turned off forever, but only that this is a troubleshooting step to determine whether we need to try to identify a rogue app with Bluetooth permissions.

I will give that a try, though it will be not easy to remember all the time… Not sure which will be the more troublesome, however. Forgetting to check my WI-FI connection when I return home (one step) or turning off my Bluetooth before I get home and then turning in back on when I get there and have checked my WI-FI. The big advantage to the smartwatch is when I am away, especially when driving as our state now has strict prohibitions against using phones in the car. With the smartwatch I can see who is calling, etc. at just a glance.

Thanks @dh2a,

Maybe Saturday you might have some time to test - perhaps a nice walk just to get out of range of the home Wi-Fi, turn off Bluetooth, and walk back.

Although, depending on where you are, a “nice walk” might not be possible this time of year. :cold_face:

Good Morning @dh2a,

Were you able to get the suggested nice walk in (weather permitting) or otherwise sort this?

1 Like

Weather here is not condusive to walks outdoors (temps in single digits yesterday) but my 5 recent experiences have been as follows: 1 occurance with smartwatch in airplane mode (no bluetooth) - no problem, phone connected to WIFI and internet; 3 occurances with smartwatch bluetooth connected - no problem, phone connected to WIFI and internet; 2 occurances with smartwatch bluetooth connected - WIFI connected but no internet. In one of these situations, I put the smartwatch in airplane mode, turning off internet and then swapped back and forth between my two WIFI nodes which is my usual remedy and it took about a dozen times before it reconnected to the internet. The other time it connected on the first swap.

So there is not yet a firm cause and affect but it appears to be somehow related to the bluetooth on the smartwatch. I do have an android tablet which of course does not have the smartwatch software but does connect to WIFI and the internet without fail.

Hi @dh2a,

Could you let us know what kind of smartwatch you’re using, and the app name that goes with it?

It might be possible to narrow this down some more, to a specific option within the app.

It is a Huawei (1st edition, I think there may be later models) and it is managed by a Wear OS application v 2.31 from the Android Play Store.

I do not have any of the devices you are experiencing problems with, but with many problems a good place to start is to ensure you have the latest and a clean version of the codes involved.

  • I just loaded Wear OS to my phone to check the code level and it is 2.31.0.284190117.GMS
    You may want to uninstall the current level and then download and install the latest code
1 Like

That is the same level that is installed on my phone. Sorry, I did not put in all of the trailing digits in my response.

ok, thanks for the confirmation. At this point the only thing I can think of to suggest is to clear the System Cache and the individual app cache for your watch.

Message an
Expert customer