WiFi "not in range"


#1

I have a 2 week old Moto G that has been working fine. Today I came home and tried to connect to my network. My laptop is connecting OK, but my phone says the network is not in range. It sees other networks in the neighborhood, but not mine. I have a Kyocera Hydro (Android) that used to do this also. I have reset the router but that doesn’t help. When the Hydro would do this, my only solution was to do a factory reset, then it would see the network. I would rather not have to do this every time this happens to the Moto G. I tried the WPS option and it did nothing. I never have this problem with my HP laptop. Is this an Android bug? A Google search finds others with this same problem. Any suggestions on what to do?


#2

That’s an odd one. What if you, from the phone, turn Wi-Fi off, wait a bit, then turn it back on?

What’s the make/model of Wi-Fi router, and what kind of security (encryption) is being used? WEP, WPA, WPA2 are your choices there.


#3

I see this too from time to time. I actually have to wifi routers in the house (opposite ends) and sometimes when I move well into the range of one of them it shows as “not available”. Usually doing a rescan of available routers solves it though without having to turn wifi off/on.


#4

Try rebooting the phone. Also try forgetting the network, and then see if you can “see” the router. Have you given your home router a unique identifier? Or is it still the default?


#5

This may be a problem that requires both Android and Zyxel to happen, guessing that one of them is doing something that is “not quite right”. Or it might be peculiar to something unique about your Wi-Fi setup in the Zyxel. Unfortunately, troubleshooting this problem may resemble searching for a needle in a haystack.

On the phone side, less destructive things than a factory reset you can try are:

a) Reboot the phone (press and hold power, tap Power off, wait a bit, turn it back on)

b) Clearing the Cache

On the Zyxel side, if it’s not the router itself, sometimes there can be issues for odd Wi-Fi names (SSID) or lengthy/strange Wi-FI passwords. So you could try changing the SSID or password to something simple and short (but not too short for the password - 10-12 characters, alphanumeric only), and see what effect that has on the problem over time.


#6

Clearing the cache did nothing. My network is “wireless 2” and I have a 10 character alpha numeric password. It seems to be an Android issue after searching the net. Again, I never have this problem with my laptop that I’ve had for 2 years now. I’ve had the router since 2011 and never saw this problem till I got the android phones.


#7

I found this interesting possibility for you here:

I just had the same problem and fixed it.

Sometimes routers are configured to select and use the less crowded wireless channel. That can cause your wifi to eventually use channel 12 or 14. Like sleepyguy007 said, it is more likely to happen if there are too many wifis in the area and all channels are crowded.

As far as I know, Android devices are by default configured to scan only up to channel 11. So if the wifi is in 12 or 14, it will not be recognized.

Go to the wifi config screen, where all the networks are listed. There, with the menu button, go to “Advanced”->“Regulator domain” and set Android to scan all 14 channels, that should do the trick.

I hope that is the cause of the problem and you can fix it… Otherwise it could be a bug, and the solution may be harder

Doesn’t look like the Moto X has the option to go beyond channel 11, but if your Zyxel router is configured for automatic channel selection, try setting its channel to the least-used channel in your vicinity, choosing only from these choices: 1, 6, or 11. You can find what other Wi-Fi is doing in your neighborhood using Wifi Analyzer - Android Apps on Google Play.


#8

Well, there seems to be some commonality here. Since the Moto G is dead in the water as far as WFi is concerned, I was going to load your wifi analyzer on my Hydro and see what’s going on. Well, guess what? The Hydro now, also refuses to see the network. My only option now, since both phones have no net connection, (I’m on the $10 plan) is to do a factory reset on the Hydro and load the analyzer on there. I have nothing important on that phone. Just some apps.


#9

Update: I factory reset the Hydro and it still would not see my network. Therefore, I could not load the Wi-Fi analyzer .Since I could not determine which channels were being used, I went into the router configuration and just chose a random channel ( 6 ). Immediately, both phones saw my network and allowed me to connect. So as suggested in carlh’s post, my router was using a channel above the phones’ capability. That’s why they did not even see the network. Thank you for this fix! Being on the $10 plan, no Wi-Fi, basically bricks the phone. As I stated earlier, I factory reset the Hydro several times to solve this problem. Now, I won’t have to do this anymore.

One question: Why am I supposed to only choose channels 1, 6, or 11? What’s wrong with 2,3,4 or maybe 8,9 or 10?


#10

Yippee! Now do go ahead with getting the Wi-Fi analyzer app and check to see if channel 6 is crowded, because that might affect the quality of your Wi-Fi calls. And (oops) sorry that I overlooked the challenge of getting an app from the Play store when a phone can’t access Wi-Fi.


#11

miqie wrote:

One question: Why am I supposed to only choose channels 1, 6, or 11? What’s wrong with 2,3,4 or maybe 8,9 or 10?

The real question is, why did they give us channels 2, 3, 4, 5, 7, 8, 9 and 10 when using them can cause problems. Can’t answer that one. But here’s some reading material on why you should use only 1, 6, or 11:

How to boost your WiFi speed by choosing the right channel | ExtremeTech

Cliff notes: nearby Wi-Fi chennels must be separated by 5 spots to avoid interference with those neighbors. When avoiding interference is impossible, choose the channel where the competition has the weakest signal.


#12

For anyone having problems understanding Channel Selection as it relates to performance of your Phone & Router/AP environment … consider the following application

  • WiFi Analyzer - Android Apps on Google Play (nearly the same name but different than Wifi Analyzer that is normally recommended)

  • It has a couple of unique functions that could be helpful

    1. An option to check that will remove from view any Router/AP signal that is not overlapping (and thus not interfering with you)
    2. Analyze function, that performs some key checks for you and presents the results in easy to understand form
      Example 1
  • 1st view on the left, shows three signals, potentially interring with each other, as there is not 25dBm to -30dBm separating them (wider separation is better)

  • By checking the ‘Only overlapping networks’ the app will check for you, eliminates the guessing when someone is using the non 1/6/11 standards and haven’t taken others in consideration. Rule of thumb…If you neighbors are interfering with your signal, you are probably bothering them also

Screenshot_2014-07-03-10-12-25.pngScreenshot_2014-07-03-10-02-53.png

Example 2

Analyze function … makes a series of checks and provide you a snapshot analysis (levels and speeds are between the phone and the router/AP)

**You want to look like this ** **NOT like this **

Screenshot_2014-07-09-08-52-34.pngScreenshot_2014-07-09-08-50-30.png

Ben ~ user since 2012 ~ not a Republic employee


#13

I know this is an older thread, but I thought I’d add my experience for anyone who searches this topic.

My wife and I both have Moto Gs. A few days ago they just stopped accessing the wifi in our house, giving the network “Not Found” message under the network name in Settings – even when just inches away from the router.

This thread got me thinking about crowded channels. I checked my router, an Airport Extreme, and it was set to channel 6. I changed it to Automatic, where the router will use the least used channel in the area, and both phones connected instantly.

Just FYI. If you’re searching this topic – Good luck!