Won't connect to WiFi

#1

Recently my MotoG5 plus has not been connecting to the WiFi in my house, it had been connecting automatically with no issues prior to this. There has been no password change on the network, so that is not the issue. All other phones and devices in the house are still able to connect. My phone will connect to other WiFi networks (work, Starbucks, etc.) but will not connect in my house. Help please! I don’t live burning through cell data in my house, kinda defeats the idea behind the phone :wink:

#2

A neighbor may have changed channels, upgraded their router etc … or you may have moved some furniture around etc.

  • I would start with the first step in the Quick Start section of Router Tweaks … this will provide a controlled power cycle of your network equipment.
#3

Try Forgetting the wifi network in your phones wifi settings, and reconnecting.

2 Likes
#4

I’ve done all the router tweeks and “forgot” the password to re-enter it. I’m still only connected to cell at my house. My WiFi network is listed, when I try to connect it says “Authenticating…” then changes to “Saved”. I was at work all day with no issues on my work network. The other RW phones in my house are working fine on the same WiFi I can’t access.

#5

If I ‘Forget’ then type an invalid PW for my home router, I see it go to Authenticating then Saved, however if I wait a bit it cycles through the sequence(multiple times), but ends up with Authentication problem.
It never shows Obtaining IP Address and never goes connected.

  • Did you power off/recycle the router, as they can get hung and ignore a specific MAC address occasionally
  • If you ‘Forget’ one of your working devices, can you re-authenticate without any problems?
1 Like
#6

Did you get this issue resolved @joshuab.4pfxsc?.

I have seen what @jben describes, cycling a couple of times.

#7

I have the same problem on my G4 and I have used lots of data because I didn’t realize it was always on cell.It does not show my WIFI just the extensions but apparently they might as well be the neighbors because it does not recognize those either.If I try and reenter my network with the information and the password the “SAVE” button is grayed out and won’t let me save. I think the time frame that this starting happening is pretty much the same as the original poster.It does not look like anyone resolved this. Maybe time to move on from Republic. IF anyone has resolved this please post.!!!

#8

The most common cause of the grayed out Connect button is the password is too short. Most routers now require 8 characters to be valid and do not lite up the Connect button until the 8th is entered.
Could you try this?

  • Access: Settings/Backup & Reset
    • Select and apply ‘Network settings reset’ … this will wipe all your ‘Saved’ PW’s
  • Select any locked network (other than your own)
    • Type 8 characters … did the 'Connect Button ’ lite up on the 8th character?
      • If NO, then boot up in Safe Mode and repeat the above steps
      • If YES then continue
  • Select your own SSID/Network Name
    • Check the Show password box
    • Type in your password … what happens on the 8th character?
2 Likes
#9

It is longer than 8 characters.It has come back for now.I will keep a close eye on the phone and see if it throws it off again. Thanks

2 Likes
Message an
Expert customer