Xfinity keeps connecting


#21

I have the same problem with my Defy phone. Although my home account is Comcast, my phone gets hijacked by local xfinity hotspots.

This won’t solve your problem if you are not a premium or higher level xfinity/comcast account holder.

Without an account you can be a guest for a total of 2 hours per month with no log in, but how do you control that if your access is hijacked?

If you have a household Comcast account of a premium level, you can add use your Comcast log-in and user name, same one as you would use to log in to pay your bill.

you can have up to 5 people added to that account with their own log in. It’s part of comcast service. It took a 38 minute phone call to xfinity tech- 855-308-9454. You will need to be authorized by the main account holder, and need that information, their phone number, name last 4 digits of ssi and their authorization, which xfinity accepted over the phone.

personally I don’t especially like this solution, because it forces you to use Xfinity weather you like it or not.

I think the new hotspots are stronger, and therefore my local account shows as not working, even though it’s up and running for computers.

Sarah


#22

I have xfinity for internet service only. When I signed up, I had just purchased a netgear wireless router for the verizon service that I canceled because of cost. So I purchased my own router, since I did not want to pay to rent the one from comcast. When they started the wifi hotspot feature shortly after I started service, I was quite happy to be able to pick up hotspots around town and even when traveling to another state (Florida), because I found places I was able to use hotspots of cable companies their which were affiliated with comcast. Anyway, I do not have the problem at home because my modem and router are not comcast hotspots since they are not comcast provided. You also have the ability from your comcast account of opting your home wifi out of being a hotspot. Not sure if that would affect your ability to use the hotspots around town, but I would think not since I can use them. So, I believe you could purchase your own modem/router and not have the problem at home, or opt your home wifi out. Hope this helps. Good luck!


#23

Does anyone have a solution? I never want my phone to ever go to Xfinitywifi! I selected to forget the network. Every time I drive past an Xfinitywifi antenna my phone still connects and goes to the login screen which pops up over whatever I have open. When I’m using my phone for directions, this is not only annoying, but dangerous. If anyone has solved this, please let us know. Thanks!


#24

Hi @ronanl,

I solved this last time I was visiting my grandmother. A neighbor of hers is transmitting an Xfinity network.

I actually re-did these steps several times over the course of my visit, because I was talking to someone else about the issue at the time, and wanted to be sure I had it right.

In my case, I have the following settings in the Republic Wireless app:

On the RW app’s Settings screen tap Wi-Fi settings.

Make sure “Ask me to join Wi-Fi networks” is selected.

With that selected, when I visited my grandmother, I was in her apartment just a few minutes before my phone showed this screen:

150415XfinityPrompt.png

In that white “Tap to connect” box, I tapped the three stacked dots on the right.

That gave me the following options:

150415XfinityPromptBlacklist.png

I tapped “Always” and after that, I could come and go as I pleased without ever seeing the Xfinity network again. (In order to force the options so I could reproduce the steps, I uninstalled the updates to the RW app, and re-install them, in order to clear all the data out of the app for a fresh start.)

 SouthpawKB, customer since 2011, not a republic wireless employee

#25

When driving you could then Wi-Fi off or use


#26

Turn off wifi.

but fwi, RW app has gotten more aggressive lately in forcing wifi.

I was in a place that had wifi i didn’t have access to but the phone keep turning wifi back on and trying to connect.


#27

@jben

This issue of xfinity booting off of our home wifi and generally inserting itself everywhere is still a huge issue for my husband’s Moto G (I have the Moto X, and no problem at all). On the Moto G, xfinitywifi is not even an option in the Manage Networks area. The phone will not even let me move it around in the list of networks. When I “forget” the network, it is back in the list within 10 minutes. It is constantly interrupting perfectly good service inside our home with a great wifi connection. This problem didn’t start until the RW app update that encourages greater wifi connection. Have you seen any information about a fix for this? I know you don’t work for RW, but you seem conscientious about this issue. Thanks!


#28

Have you uninstalled the Republic application, turned the phone off and back on, reinstalled the Republic application and then followed @southpawkb instructions in this thread?


#29

@jben

Thanks so much for trying to help! I have tried everything I can think of to attempt to uninstall the Republic Wireless app, but it does not seem like it’s able to be uninstalled. There is a grayed-out, unavailable button that says “Uninstall Updates.” I have read the user’s guide, but the instructions there don’t work:

Uninstall: To uninstall apps, touch Apps, touch and hold an app, then drag it to Uninstall (if available).

When I try to do this, there is NO option to uninstall. There is only the option to place the app icon on the home screen.

I welcome (truly), any and all other suggestions!


#30

Hi @jenl,

You can’t uninstall the Republic Wireless app.

You can, however, uninstall its updates, then re-install them. What this accomplishes, is clearing all the settings in the app so it’s like it has been newly installed and updated on the phone. Since it has the “Clear Data” button disabled, this is a way to sweep out the cobwebs and give it a fresh start.

Note: uninstalling and re-installing the RW app’s update will delete all the “data” in the app - you will no longer see your past cellular usage history, so take screenshots if you want that preserved. Any configurations you have set, such as Wi-Fi network auto-joining, saved captive portal authentications, and handover management (whitelisting) will be forgotten.

To uninstall and re-install the updates to the Republic Wireless app, please follow these steps while connected to a Wi-Fi network:

  1. Open the Play Store app on the phone.
  2. Tap the menu button at the upper left.
  3. Tap My Apps
  4. Find Republic Wireless in the list, and tap it.
  5. Tap Uninstall. If there’s no Uninstall button, skip to step 9.
  6. Hold down the power button, then tap Power Off from the menu, and confirm.
  7. Turn the phone back on.
  8. Return to the Play store and tap the Republic app as before (steps 1-4)
  9. Tap Update.
 SouthpawKB, customer since 2011, not a republic wireless employee

#31

Sorry … I neglected to specify how to uninstall the updates, but @southpawkb has covered the how to above

Ben ~ a Community member - not an employee of Republic


#32

@southpawkb

THANK YOU!!! Got it. Now, we’re just waiting for the prompt so that we can choose “ALWAYS” in response to “Forget this Network?”


#33

jenl wrote:

@southpawkb

THANK YOU!!! Got it. Now, we’re just waiting for the prompt so that we can choose “ALWAYS” in response to “Forget this Network?”

You’re welcome, @jenl,

In the RW app, now that you’ve reset it, make sure you’ve told it to prompt you.

Open the RW app.

Tap the settings gear at top, right.

Tap “Wi-Fi Settings.”

Make sure “Ask me to join Wi-Fi networks” is checked.

 SouthpawKB, customer since 2011, not a republic wireless employee

#34

Yep, got it! Thanks!


#35

I typically turn off wifi when driving. Bright House and others keep turning off my map program. This can probably be fixed. I don’t care to play cat and mouse. I just turn it off .


#36